[uClinux-dev] rrdtool: crashing when rendering graphics (m68k target)

Luis Alves ljalvs at gmail.com
Fri May 4 16:30:15 EDT 2012


Thanks a lot Greg! Increased the stack size and it works now!
By default it is set to the 4k default.

Always learning!

Thanks and Regards,
Luis Alves

No dia 4 de Mai de 2012 14:41, "Greg Ungerer" <gerg at snapgear.co
>
> Hi Luis,
>
> On 05/04/2012 07:58 PM, Luis Alves wrote:
>
>> I've tried the 'rrdtool' included in the latest uClinux dist (20120401).
>> Creating the database, inserting and fetching values work fine, but
>> when I try to create a .png chart it do one of these two things:
>> 1) Crash the kernel (I'm almost sure it writes in bad memory locations)
>> 2) Give an 'Address Error' trap.
>>
>> Before I start to dig the code to find the issue (if I ever get time
>> to do it), has anyone used this tool in a m68k target? If yes, does it
>> work good?
>> What about in other nommu targets?
>>
>
> I haven't used rrdtool on uClinux, so I can't verify that it works.
>
> But when you see these sorts of odd crashes the first thing I try
> is to increase the stack size of the app. Its all too easy to overrun
> your app stack.
>
> If you grep for FLTFLAGS in user/*/Makefile you will see how to
> set a larger stack size.
>
> Regards
> Greg
>
> ------------------------------**------------------------------**
> ------------
> Greg Ungerer  --  Principal Engineer        EMAIL:     gerg at snapgear.com
> SnapGear Group, McAfee                      PHONE:       +61 7 3435 2888
> 8 Gardner Close,                            FAX:         +61 7 3891 3630
> Milton, QLD, 4064, Australia                WEB: http://www.SnapGear.com
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.uclinux.org/pipermail/uclinux-dev/attachments/20120504/76e43eea/attachment.html>


More information about the uClinux-dev mailing list