[uClinux-dev] what i did..samsung s3c4510b

Greg Holdren greghol at sbcglobal.net
Fri Jan 27 00:32:59 EST 2006


Here is the basic instructions on how to add an application to the build. Its pretty straight forward when following the instructions.

http://www.lumit.org/download/document/lumit-uclinux-addapp-readme.txt

Greg
  ----- Original Message ----- 
  From: nidhi 
  To: uclinux development list 
  Sent: Thursday, January 26, 2006 8:38 PM
  Subject: [uClinux-dev] what i did..samsung s3c4510b


  Dear all: i would like to tell you all the steps what i tried,so that you can sujjest me where i am goin wrong. 

  1. copied uclinux-Samsung xxxxxx.tar.gz and arm-elf-tools.sh to /usr 
  2. installed the toolchain by the command   sh arm-elf-tools20040427.sh
  3. untared the source by tar -xzvf uclinux-Samsungxxxx.tar.gz
  4. created a folder hello in uclinux-Samsung/user
  5. in hello folder created two files a Makefile and a hello.c

  hello.c:
  include<stdio.h>
  int main(void)
  {
   printf(" hello");
  return (0);
  }

  Makefile:
  EXEC = hello
  OBJS = hello.o
  all: $(EXEC)
  $(EXEC): $(OBJS)
  $(CC) $(LDFLAGS) o $@ $(OBJS) $(LDLIBS)
  romfs: $(ROMFSINST) /bin/$(EXEC)
  clean: rm romfs:

  6.in the user/Makefile added this line
     DIR_$(CONFIG_USER_HELLO_HELLO) += hello
  7.configure/config.help added line 
    CONFIG_USER_HELLO_HELLO
     sample test hello
  8.in configure/config.in under miscellaneous applications added
  'bool' hello  CONFIG_USER_HELLO_HELLO

  9. make menuconfig 
      i have selected update vendor settings,update kernel settings
   and checkmarked (selected) the 'hello' under miscellaneous applications.
  10. make dep
  11. make user_only 
  12.make lib_only
  13.make romfs
  14.make image
  15.make

  but while making romfs it says that cannot'stat' hello file or folder not found.

  here the file 'hello' in romfs/bin is not found

  later i found that. it is not creating any binary executable file...coz one sample example is already attatched in the dist and if i remove it , the same lines appear saying"cannot stat'sample' the file or foldr is not found"and it is not creating it again.
  here also the 'sample' under romfs/bin is not found.


  please help me ......

  or if you want me to try out some more.. please.....
  regards,
  nidhi.







------------------------------------------------------------------------------


  _______________________________________________
  uClinux-dev mailing list
  uClinux-dev at uclinux.org
  http://mailman.uclinux.org/mailman/listinfo/uclinux-dev
  This message was resent by uclinux-dev at uclinux.org
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.uclinux.org/pipermail/uclinux-dev/attachments/20060126/75756f71/attachment.html>


More information about the uClinux-dev mailing list