[uClinux-dev] SSHD in MicroBlaze: BINFMT_FLAT: reloc outsideprogram

John Williams jwilliams at itee.uq.edu.au
Mon Jan 23 21:49:17 EST 2006


DeviPrasad Natesan wrote:
> Hi Gavin,
> I do use the following flags in the config.arch
> 
> DISABLE_XIP = 1
> DISABLE_SHARED_LIBS = 1
> DISABLE_MOVE_RODATA = 1
> DISABLE_SHARED_SSL=1
> 
> Should i need to add something more.?

Shared Libs and XIP are all ignored in MicroBlaze currently, and should
have no effect.

John

> 
> thanx
> - Prasad
> 
> On 1/23/06, Gavin Lambert <gavinl at compacsort.com> wrote:
> 
>>I had this sort of thing occur when the Has-PIC-GOT flag got turned on,
>>which happened whenever XIP was active.  Only workaround I found at the
>>time was to disable XIP entirely.  Didn't really spend too long looking
>>for alternatives, though, because XIP wasn't really a biggie for me
>>anyway.
>>
>>
>>>-----Original Message-----
>>>From: DeviPrasad Natesan
>>>Sent: Tuesday, 24 January 2006 14:39
>>>Subject: Re: [uClinux-dev] SSHD in MicroBlaze: BINFMT_FLAT:
>>>reloc outsideprogram
>>>
>>>
>>>Hi John,
>>>Thanx for responding. I ran with -v option. I got the
>>>following i am not quite sure how to  interpret it. (This
>>>time the address and the error is 0x1577a4 i searched for all
>>>of it and cut-n-pasted that line).
>>>
>>>=======================================
>>>RELOC[373]: offset=0x2ab0 symbol=options+0x9594 section=.bss
>>>size=4 fixup=0x1577a4 (reloc=0x2ab0)
>>>RELOC[554]: offset=0x4a50 symbol=options+0x9594 section=.bss
>>>size=4 fixup=0x1577a4 (reloc=0x4a50)
>>>RELOC[719]: offset=0x787c symbol=options+0x9594 section=.bss
>>>size=4 fixup=0x1577a4 (reloc=0x787c)
>>>RELOC[765]: offset=0x7ea4 symbol=options+0x9594 section=.bss
>>>size=4 fixup=0x1577a4 (reloc=0x7ea4)
>>>RELOC[824]: offset=0x9368 symbol=options+0x9594 section=.bss
>>>size=4 fixup=0x1577a4 (reloc=0x9368)
>>>RELOC[1261]: offset=0xf300 symbol=options+0x9594 section=.bss
>>>size=4 fixup=0x1577a4 (reloc=0xf300)
>>>RELOC[1312]: offset=0xffc8 symbol=options+0x9594 section=.bss
>>>size=4 fixup=0x1577a4 (reloc=0xffc8)
>>>RELOC[1798]: offset=0x160d0 symbol=options+0x9594
>>>section=.bss size=4 fixup=0x1577a4 (reloc=0x160d0)
>>>===========================================================
>>>
>>>BTW, my root file system is in jffs2 based flash partition
>>>and it is read-only (and i used u-boot to boot the linux from
>>>the file system). So the possibility of other program
>>>corrupting the relocation information in the header in the
>>>file is nil (am i right?).
>>>
>>>I have almost all of the other utilities in my /bin works
>>>fine. Only sshd gives me this error.
>>>
>>>I have not tried NFS mount till now with my board. If that is
>>>the last option, i will try it.
>>>
>>>Please let me know is there anything else i can do to debug
>>>this problem.
>>>
>>>Thanx and i appreciate your reply.
>>>- Prasad
>>
>>_______________________________________________
>>uClinux-dev mailing list
>>uClinux-dev at uclinux.org
>>http://mailman.uclinux.org/mailman/listinfo/uclinux-dev
>>This message was resent by uclinux-dev at uclinux.org
>>
> 
> _______________________________________________
> uClinux-dev mailing list
> uClinux-dev at uclinux.org
> http://mailman.uclinux.org/mailman/listinfo/uclinux-dev
> This message was resent by uclinux-dev at uclinux.org


-- 
Dr John Williams, Research Fellow,
Embedded Systems Group / Reconfigurable Computing
School of ITEE, The University of Queensland, Brisbane, Australia
(p) +61 7 33652185  (f) +61 7 33654999 (m) +61 403969243



More information about the uClinux-dev mailing list