[uClinux-dev] Re: uClinux-dist-20051014 build FAILS

Paul G. Allen pgallen at gmail.com
Mon Oct 24 11:26:43 EDT 2005


REPOST


make xconfig fails. This has been the case with every version of
uClinux since I have been working with it. I imagine (as has also been
the case with all other version) that this is only the first of
several failures I will run across. Configuration is for GDB and
ARMULATOR. Linux 2.6 kernel, armnommu, default all settings. See
failure mode below:

. . .
. . .
. . .
Enable security options (UCLIBC_SECURITY) [N/y] n
*
* uClibc development/debugging options
*
Build uClibc with debugging symbols (DODEBUG) [N/y/?] n
Build uClibc with run-time assertion testing (DOASSERTS) [N/y/?] n
Manuel's hidden warnings (UCLIBC_MJN3_ONLY) [N/y/?] n
make[2]: Leaving directory `/usr/local/Quake/uClinux-dist-20051014/uClibc'
make[1]: Leaving directory `/usr/local/Quake/uClinux-dist-20051014'
make[1]: Entering directory `/usr/local/Quake/uClinux-dist-20051014'
make ARCH=armnommu CROSS_COMPILE=arm-elf- -C linux-2.6.x xconfig
make[2]: Entering directory `/usr/local/Quake/uClinux-dist-20051014/linux-2.6.x'
Makefile:447: /usr/local/Quake/uClinux-dist-20051014/linux-2.6.x/arch/armnommu/Makefile:
No such file or directory
make[2]: *** No rule to make target
`/usr/local/Quake/uClinux-dist-20051014/linux-2.6.x/arch/armnommu/Makefile'.
 Stop.
make[2]: Leaving directory `/usr/local/Quake/uClinux-dist-20051014/linux-2.6.x'
make[1]: *** [linux_xconfig] Error 2
make[1]: Leaving directory `/usr/local/Quake/uClinux-dist-20051014'
make: *** [xconfig] Error 2
[root at telgar uClinux-dist-20051014]#



I have 'fixed' this in past versions, but I'm not sure it was the
proper fix and I have always thought a regular maintainer would fix it
the right way. Also, since I have yet to get any uClinux kernel to
build and run, I can't say if any patch I submit would not create more
issues than it solves.

PGA
--
Paul G. Allen
Software Engineer, BSIT/SE
QUAKE Global, Inc.



More information about the uClinux-dev mailing list