[uClinux-dev] could you lend me a hand? I can not cross-compile libgpg-error libgcrypt for my arm-clinux system.

David McCullough davidm at snapgear.com
Thu Oct 20 23:17:26 EDT 2005


Which uClinux-dist version are you using ?

Jivin lmzhang lays it down ...
> hi , 
>   
>     I want to cross-compile libgpg-error,libgcrypt for my uclinux with a
> ARM9 which is nommu. 
> 
> ###################################
> CONFOPTS :=	--enable-dependency-tracking \
> 		--prefix=$(ROOTDIR)/lib/libgpg-error/inst
> 
> all: build/build
> 	$(MAKE) -C build install
> 
> build/build: makefile
> 	@chmod u+x configure
> 	@rm -rf build
> 	@mkdir build
> 	(cd build; ../configure --host=$(CROSS_COMPILE:-=) $(CONFOPTS))
> 	@touch build/build
> 
> clean:
> 	rm -rf build
> #####################################
> 
> I run the config following ...
> 
> mkdir build;cd build;../configure --host=arm-elf $(CONFOPTS) ,
> there are some erros,such as" arm-elf-gcc can not execute... ,arm-elf-gcc cannot compute..."
> meanly, my arm-elf-gcc 2.95.3 can not create a.out by runing "arm-elf-gcc -c conftest.c".
> 
> there is same problem while I compile the libgcrypt-1.2.1....
> 
> so can you give me some ideas to help me out.
> thanks a lot in advance for any help.

-- 
David McCullough, davidm at cyberguard.com.au, Custom Embedded Solutions + Security
Ph:+61 734352815 Fx:+61 738913630 http://www.uCdot.org http://www.cyberguard.com



More information about the uClinux-dev mailing list