[uClinux-dev] header intact

zhangbin zylwmg at 163.com
Tue Oct 18 21:04:46 EDT 2005


uclinux-dev-request,您好!

	      confirm c5a98238919047d7f3cbb78f9b6b9af0ac3db10c
>

======= 2005-09-18 00:00:06 您在来信中写道:=======

>Send uClinux-dev mailing list submissions to
>	uclinux-dev at uclinux.org
>
>To subscribe or unsubscribe via the World Wide Web, visit
>	http://mailman.uclinux.org/mailman/listinfo/uclinux-dev
>or, via email, send a message with subject or body 'help' to
>	uclinux-dev-request at uclinux.org
>
>You can reach the person managing the list at
>	uclinux-dev-owner at uclinux.org
>
>When replying, please edit your Subject line so it is more specific
>than "Re: Contents of uClinux-dev digest..."
>
>
>Today's Topics:
>
>   1. CF card can't be mount on uclinux 2.4 !
>      (=?gb2312?B?0KQgZHJhZ29u?=)
>   2. keyboard and console (devi)
>
>
>----------------------------------------------------------------------
>
>Message: 1
>Date: Sat, 17 Sep 2005 11:00:02 +0800
>From: =?gb2312?B?0KQgZHJhZ29u?= <dragon83721 at hotmail.com>
>Subject: [uClinux-dev] CF card can't be mount on uclinux 2.4 !
>To: uclinux-dev at uclinux.org
>Message-ID: <BAY14-F2416E2A21E31750CD89AEDE1900 at phx.gbl>
>Content-Type: text/plain; charset=gb2312; format=flowed
>
>Hi!
>     i loaddown loader.bin in 0x000000 and the romfs.bin in the address of 
>0x006000 . my uclinux system was loaded .but it can't mound the vfat 
>filesystem from CF card . I didn't have a IDE disk .i have to use the CF 
>insterd
>
>     The information of the errors :
>=================================================================
>EM85xx Bootloader v1.0.0 (Nov 19 2004 17:24:07)
>
>Found romfs @ 0x00006000
>Volume Name: pvp application
>linux.bin.gz (looking up...)
>.
> ..
> bin
> hd1
> dev
> etc
> img
> cdrom
> hd2
> hzk12
> hzk16
> khwl.o
> irdrv.o
> ata.o
> minimod
> piodrv.o
> linux.bin.gz
> Found
>Unzipping image from flash
> From: 001F2A50
>To: 01008000
>Size: 0005099A
>Inptr=
>00000014
>Inflating....
>OutCnt = 000A3C40
>Final Inptr=00050992
>Original CRC =0066D588
>Computed CRC =0066D588
>01008000Linux version 2.4.17-uc0 (root at localhost.localdomain) (gcc version 
>2.95.
>3 20010315 (release)) #1 Sat May 28 17:47:26 EDT 2005
>Processor: ARM pt110 revision 0
>Architecture: JASPER
>On node 0 totalpages: 1920
>zone(0): 1920 pages.
>zone(1): 0 pages.
>zone(2): 0 pages.
>Kernel command line: root=/dev/root
>setup_timer: Timer value = 42187
>serial_jasper: setup_console @ 38400
>jasperuart change speed 109
>Calibrating delay loop... 67.17 BogoMIPS
>Memory: 7MB = 7MB total
>Memory: 6732KB available (475K code, 272K data, 32K init)
>Dentry-cache hash table entries: 1024 (order: 1, 8192 bytes)
>Inode-cache hash table entries: 512 (order: 0, 4096 bytes)
>Mount-cache hash table entries: 512 (order: 0, 4096 bytes)
>Buffer-cache hash table entries: 1024 (order: 0, 4096 bytes)
>Page-cache hash table entries: 2048 (order: 1, 8192 bytes)
>POSIX conformance testing by UNIFIX
>Starting kswapd
>devfs: v1.7 (20011216) Richard Gooch (rgooch at atnf.csiro.au)
>devfs: boot_options: 0x1
>pty: 256 Unix98 ptys configured
>block: 64 slots per queue, batch=16
>Blkmem copyright 1998,1999 D. Jeff Dionne
>Blkmem copyright 1998 Kenneth Albanowski
>Blkmem 1 disk images:
>0: 6000-25D7FF [VIRTUAL 6000-25D7FF] (RO)
>Making root root
>FAT: bogus logical sector size 60384
>FAT: bogus logical sector size 60384
>VFS: Mounted root (romfs filesystem) readonly.
>Mounted devfs on /dev
>Freeing init memory: 32K
>serial_core: try baudrate 38400
>jasperuart change speed 108
>serial_core: try baudrate 38400
>jasperuart change speed 108
>Using /khwl.o
>PIO: init_module
>PIO: device (128:0) registered in devfs
>PIO: irq 5 obtained
>PIO: irq 6 obtained
>PIO: init_module ok
>Using /irdrv.o
>Using ide-mod.o
>Uniform Multi-Platform E-IDE driver Revision: 6.31
>ide: Assuming 50MHz system bus speed for PIO modes; override with idebus=xx
>JASPER ide controller activated
>    ide0: BM-DMA at 0x500e00-0x500e0f, BIOS settings: hda:pio, hdb:pio
>Using ide-probe-mod.o
>IDE device status = 40
>IDE drive 0 not present
>IDE drive 1 present
>hdb: SunDisk SDCFB-4, ATA DISK drive
>ide0 at 0x500bf0-0x500bf7,0x500be6 on irq 11
>Using ide-disk.o
>hdb: ignore DMA off message.
>model            = SunDisk SDCFB-4
>firmware version = vcb 1.45
>jasper_config_drive_for_dma:
> capability    = 0x0002
> field_valid   = 0x0001
> dma_ultra     = 0x0000
> dma_1word (s) = 0x0000
> dma_mword (m) = 0x0000
> autodma       = 0x0001
>DMA disabled quietly
>hdb: ignore DMA off message.
>hdb: 7872 sectors (4 MB) w/1KiB Cache, CHS=123/2/32
>Partition check:
> /dev/ide/host0/bus0/target1/lun0: p1 p2 p4
> /dev/ide/host0/bus0/target1/lun0: p1 p2 p4
> /dev/ide/host0/bus0/target1/lun0: p1 p2 p4
>MSDOS FS: IO charset gb2312
>=========================================================================
>i can't get the shell . i don't know why ! someone can help me ? thinks!
>
>
>                                                                     yours 
>Dragon
>                                                                     17th 
>Sep,2005
>
>_________________________________________________________________
>与联机的朋友进行交流,请使用 MSN Messenger:  http://messenger.msn.com/cn  
>
>
>
>------------------------------
>
>Message: 2
>Date: Sat, 17 Sep 2005 13:59:28 +0530
>From: "devi" <devi at tenet.res.in>
>Subject: [uClinux-dev] keyboard and console
>To: uclinux-dev at uclinux.org
>Message-ID: <20050917082928.7591.qmail at mail.tenet.res.in>
>Content-Type: text/plain; charset="ISO-8859-1"
>
>hi,
>
>In inittab I have added 
>tty0:respawn:/bin/agetty -l /bin/login tty0 38400
>tty1:respawn:/bin/agetty -l /bin/login tty1 38400
>tty2:respawn:/bin/agetty -l /bin/login tty2 38400
>but when I do Ctrl+Alt+F1 and similarly Ctrl+Alt+F2 it switches from one console
>to other.But the keyboard is active only with the last console(tty2 / Ctrl+Alt+F2)
>why the keyboard is not active with tty1.
>
>
>Regards
>Devi
>
>
>------------------------------
>
>_______________________________________________
>uClinux-dev mailing list
>uClinux-dev at uclinux.org
>http://mailman.uclinux.org/mailman/listinfo/uclinux-dev
>This message was resent by uclinux-dev at uclinux.org
>
>End of uClinux-dev Digest, Vol 29, Issue 16
>*******************************************
>

= = = = = = = = = = = = = = = = = = = =
			

        致
礼!
 
				 
        zhangbin
        zylwmg at 163.com
          2005-10-19



More information about the uClinux-dev mailing list