[uClinux-dev] cross compiling

Stephane germain_stephane at hotmail.com
Thu Oct 13 20:17:54 EDT 2005


Hi,

    I tried to compile a open software that is suppose to support cross 
compile

 from the doc:
For example, to build Player on an x86/Linux system for an ARM/Linux 
system (e.g., the iPAQ), you would first configure Player like:
$ ./configure --build=i686-pc-linux-gnu --host=arm-linux --without-rtk

After put my cross compile directory first in my path (from the doc!)
/$ export PATH=/usr/local/m68k-elf/bin:$PATH
/My cross compile tool:
m68k-elf-tools-20031003.sh

I tried:
/$  ./configure --build=i686-pc-linux-gnu --host=m68k-elf --without-rtk/
and see the error:
/checking build system type... i686-pc-linux-gnu
checking host system type... m68k-unknown-elf
checking target system type... m68k-unknown-elf
checking for a BSD-compatible install... /bin/install -c
checking whether build environment is sane... yes
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking for m68k-elf-strip... m68k-elf-strip
checking whether make sets $(MAKE)... (cached) yes
checking for m68k-elf-gcc... gcc
checking for C compiler default output file name... configure: error: C 
compiler cannot create executables
See `config.log' for more details./


 From /config.log : (what I think pertinent!)/

[...]
configure:2467: gcc -v </dev/null >&5
Reading specs from /usr/local/lib/gcc-lib/m68k-elf/2.95.3/specs
gcc version 2.95.3 20010315 (release)(ColdFire patches - 20010318 from 
http://fiddes.net/coldfire/)(uClinux XIP and shared lib patches from http
://www.snapgear.com/)
configure:2470: $? = 0
configure:2472: gcc -V </dev/null >&5
gcc: argument to `-V' is missing
configure:2475: $? = 1
configure:2498: checking for C compiler default output file name
configure:2501: gcc    conftest.c  >&5
/usr/local/m68k-elf/bin/ld.real: cannot open crt0.o: No such file or 
directory
collect2: ld returned 1 exit status
configure:2504: $? = 1
configure: failed program was:
| /* confdefs.h.  */
[...]
 
thanks in advance

       Stephane Germain




More information about the uClinux-dev mailing list