[uClinux-dev] Initrd works only with ext2

David McCullough davidm at snapgear.com
Tue Oct 4 18:45:13 EDT 2005


Jivin Mpourtounis Dimitrios lays it down ...
> 
> Hi,
> 
> I have been using initrd with kernel 2.4.26. The initrd image was ext2 
> filesystem and everything worked right.
> 
> I tried to switch to another filesystem (jffs2), but my kernel cannot 
> mount the root (Kernel panic: VFS: Unable to mount root fs on 01:00).
> 
> I tried to use other filesystems (minix for example), the same problem.
> 
> It seems that only ext2 can be mounted.
> 
> Has anybody come across this behaviour?
> 
> Kernel has jffs2,minix etc filesystems support.

The initrd support needs to be able to identify the filesystem and work
out some details.

romfs and cramfs are also supported.

Look in linux-2.4.x/init and you should be able to find the area if you
decide to support another FS,

Cheers,
Davidm

-- 
David McCullough, davidm at cyberguard.com.au, Custom Embedded Solutions + Security
Ph:+61 734352815 Fx:+61 738913630 http://www.uCdot.org http://www.cyberguard.com



More information about the uClinux-dev mailing list