[uClinux-dev] Problem with PS, DMESG and IXP425 driver

Greg Ungerer gerg at snapgear.com
Mon Oct 3 21:41:24 EDT 2005


Hi Granzoto,

G r a n z o t o wrote:
>>What board are you using?
> 
>  I'm using this board :
> 
>    Processor       : XScale-IXP4xx/IXC11xx rev 1 (v5b)
>    BogoMIPS        : 527.56
>    Features        : swp half thumb fastmult edsp
>    Hardware        : CyberGuard/SG580
> 
>  Please, let me know if there is another information about the board I should send you...

No, that is enough.


>>What kernel version did you select?
> 
> 
>  I selected this version :
> 
>     (linux-2.4.x) Kernel Version
> 
>  And, (uClibc) Libc Version

Ok, that is all good too.


>>What version of the AccessLibrary are you using?
> 
> 
>  To Build The IXP Drivers, I'm following this steps :
> 
>    1 - tar zxvpf snapgear-3.3.0-beta0.tar.gz
[snip]
>  Are this steps corrects ?  Am I missing something ?

That all looks good too. Are they just the default
module build settings for the SG580 (from the snapgear
modules patch)?


>>I wouldn't expect so. Try runnin "ps" before loading the
>>IXP modules to check.
> 
>  I did it, and it is still crashing... 

I just did a test build for the SG580 and ran it on a board.
"ps" and "dmesg" worked ok for me.

Are your kernel and user programm configurations just the default
SG580 configs, or have you modified them in some way?

Also, what toolchain are you using?

Regards
Greg



------------------------------------------------------------------------
Greg Ungerer  --  Chief Software Dude       EMAIL:     gerg at snapgear.com
SnapGear -- a CyberGuard Company            PHONE:       +61 7 3435 2888
825 Stanley St,                             FAX:         +61 7 3891 3630
Woolloongabba, QLD, 4102, Australia         WEB: http://www.SnapGear.com



More information about the uClinux-dev mailing list