[uClinux-dev] Problems Enabling Multicast - 2.6 kernel

John Dugan John.Dugan at NovaTechPS.com
Sun Oct 2 17:39:13 EDT 2005


I am trying to enable multicast so that I can receive multicast packets.

 

I set the menuconfig item under networking "IP: multicasting" to Yes.
This seems to build, although I get some warnings.  But when I run the
kernel, it won't start up.  I get the following:

 

NET: Registered protocol family 2

IP: routing cache hash table of 512 buckets, 4Kbytes

TCP: Hash tables configured (established 512 bind 512)

NET: Registered protocol family 1

NET: Registered protocol family 17

RAMDISK: Couldn't find valid RAM disk image starting at 0.

Kernel panic: VFS: Unable to mount root fs on ram0

 

I have tried adding in some of the associated options in case this
feature requires something else to be compiled in.

 

Maybe someone has seen this gotten past it.

 

Thanks in advance.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.uclinux.org/pipermail/uclinux-dev/attachments/20051002/4fe5b5fe/attachment.html>


More information about the uClinux-dev mailing list