[uClinux-dev] user applications & kernel versions...

Robin Getz rgetz at blackfin.uclinux.org
Mon Aug 29 01:45:06 EDT 2005


I have been noticing that some of the applications in the user folders are 
pretty far out of date form the mainline projects, causing some issues when 
using the latest kernels.

I can update this & send a patch, but it might cause problems for those 
using older kernels...

some issues I have encountered so far:
   - mount is the wrong version for the 2.6 kernel
   - mkfs.jffs2 is _very_ old (1.2 is in uclinux-dist), but the latest 
(1.45) is noted not to work with the 2.4 kernel. We are running into issues 
with the 2.6.12 kernel with the 1.2 mkfs.jffs2 application.

Thoughts?

I can split them up, and compile the new apps when the new kernel is 
selected, but that seems a little crazy. (cvs is big enough isn't it? - we 
should try not put a bunch of user/2.4.x user/2.6.x code in?)

Thanks
-Robin




More information about the uClinux-dev mailing list