[uClinux-dev] ixp400.o

Doug Kehn rdkehn at yahoo.com
Sun Aug 28 09:29:50 EDT 2005


Hi Zeniab,

--- magicworld wrote:

> Hi all, 
> 
> I am using, 
> 
> Platform   : ADI/Coyote
> Kernel      : snapgear-3.3.0 beta
> Tool chain used : arm-linux 
> 
> zImage and ramdisk loaded.
> I am able to up the board. 
> 
> I attached ixp400accesslibrary-2_0.zip, but there
> was no ixp400.o for 
> insmode.
> Did any one successfully make this module for this
> platform? 
> 

I used uClinux-dist-test-20050808 but yes I have it
working.  snapgear-3.3.0 beta is either identical to
uClinx-dist-test-20050808 or _very_ close to it.

Did you also download snapgear-modules-20050812.sh,
execute it, and follow the README?  If you did, did
you also, via make {x,menu}config, configure the
library and eth's to be built?

Are you building linux-2.4.x or linux-2.6.x?  I built
linux-2.6.x.  If you are using linux-2.6.x, you need
to use modprobe instead of insmod.  BTW, for
linux-2.6.x, the library will be in:

/lib/modules/2.6.12-uc0/kernel/ixp425/ixp400-2.0/ixp400.ko

If you are using BusyBox's lsmod, insmod, modprobe,
did you configure BusyBox for linux-2.6.x modules?

Lastly, as is, only the eth attached to the 4-port
switch (ixp0) will come up.  I posted a patch
yesterday that resolves this issue.

Regards,
...doug

__________________________________________________
Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 
http://mail.yahoo.com 



More information about the uClinux-dev mailing list