[uClinux-dev] modules in 20050808 dist

Lance Spaulding lsjunk1 at cableone.net
Tue Aug 16 18:24:08 EDT 2005


I cant get modules to load correctly on the 20050808 distribution.  They 
appear to load correctly (no error message from insmod) and lsmod shows 
them being resident but they never actually execute and they dont show 
up in /proc/devices.  At first, I thought this was just my custom 
targets but I see the same failure with the armulator target and the 2.4 
kernel (haven't tried 2.6).  I know the modules are built correctly 
because they load correctly in the load distrution (based on 2.4.22).  I 
thought it was a busybox problem but I tried replacing busybox with the 
version from the old distribution and have the same problem.  Is anyone 
else able to load modules on the 2.4 kernel with the new distribution? 

Also, I'm still using the 2.95 toolchain from the uclinux.org web site.  
Is there a working 3.x toochain for arm anywhere?

Thanks in advance,
Lance




More information about the uClinux-dev mailing list