[uClinux-dev] a problem from a new user of uclinux

David McCullough davidm at snapgear.com
Mon Aug 15 19:29:16 EDT 2005


Jivin quit we lays it down ...
> Hi, I am using uclinux-dist-20030305.tar.gz. Could anybody please tell me 
> under which directory I should run the command "make xconfig", "make dep" 
> and "make"?

If you extract the archive,  you should have a directory named
uClinux-dist created.

	cd uClinux-dist
	make xconfig (choose vendor/platform etc then save and exit)
	make dep
	make

> I have tried many times, but when I run "make dep" under the 
> 'uClinux-dist', then it says there is no Makefile under linux-2.4.x/arch. 
> When I run "make dep" under 'linux-2.4.x', it seems work, but then I run 
> "make" under the same directory, it says "No rule to make target 
> 'include/linux/autoconf.h', needed by 'include/config/MARKER', stop".
> 
> Any suggestion is welcome, please email me at quit52003 at hotmail.com, thanks 
> a lot.

Cheers,
Davidm

-- 
David McCullough, davidm at cyberguard.com.au, Custom Embedded Solutions + Security
Ph:+61 734352815 Fx:+61 738913630 http://www.uCdot.org http://www.cyberguard.com



More information about the uClinux-dev mailing list