[uClinux-dev] snapgear 3.2.0/2.6.x/ixdp425 - does it work?

David McCullough davidm at snapgear.com
Thu Aug 4 22:57:27 EDT 2005


Jivin A. R. lays it down ...
> Hi all,
> 
> When I build a 2.6.x kernel + Glibc - I get two
> issues:
> 
> 1. A Build error in mtd_abi.h because of __user stuff.
> 
> 2. When I removed the __user stuff, and got it to
> compile - all I get at boottime is some garbled text.
> I even applied the -mbig-endian patch, but it didnt
> help.
> 
> Does snapgear3.2.0/2.6.x + Glibc really work on
> IXDP425? (2.4.x has no issues at all).

We tend to use uClibc for everything,  and as such,
I don't think anyone here has even tried glibc on 2.6 :-)

Cheers,
Davidm

-- 
David McCullough, davidm at snapgear.com  Ph:+61 7 34352815 http://www.SnapGear.com
Custom Embedded Solutions + Security   Fx:+61 7 38913630 http://www.uCdot.org



More information about the uClinux-dev mailing list