[uClinux-dev] floating point problem

Ramana Radhakrishnan ramana.radhakrishnan at codito.com
Thu Mar 27 11:29:53 EST 2003


Then you cant use libgcc.a . i am not sure if you get libgcc.so or 
libgcc.la for the arm port since i
have never worked on ARM anyways. for whatever its worth
ciao
ramana
On 27 Mar 2003 14:52:49 +0100, Erwin Authried <eauth at softsys.co.at> wrote:

> Am Don, 2003-03-27 um 02.14 schrieb JinSoo Kim:
>> Hi,
>>
>> Thanks very much for your help, Ramana.
>> I tried your second option, adding libgcc.a library.
>> But there was a problem when loading the module.
>> The error message is...
>>
>> "Unhandled fault: external abort on linefetch (F4) at 0x00000001
>> fault-common.c(97): start_code=0xfc0040, start_stack=0xfbff88)
>> pid 82: failed 7"
>>
>> The module was loaded but the module initialization failed.
>> I simplified my problem by making the simple code as possible as I can.
>> Here is the simple code and Makefile which make the error message when
>> loaded into the kernel.
>>
>> Is the link option I used to add libgcc.a right in the Makefile?
>> How to resolve this problem? Any advice will be much helpful.
>> Thanks in advance...
>>
> Hi,
> just an idea: Maybe you used a libgcc that is compiled with PIC support?
> You will need a lib without PIC for kernel & modules.
>
> Regards,
> Erwin
>
> _______________________________________________
> uClinux-dev mailing list
> uClinux-dev at uclinux.org
> http://mailman.uclinux.org/mailman/listinfo/uclinux-dev
> This message was resent by uclinux-dev at uclinux.org
>



-- 
God made machine language - The rest is the work of man
---------------------------------------------------------------------------- 
 --
Ramana Radhakrishnan Codito Technologies




More information about the uClinux-dev mailing list