[uClinux-dev] dist 20030305 doesn't build for Arcturus uC5272

Rene Gegusch rgegusch at mf.tu-berlin.de
Mon Mar 24 04:12:45 EST 2003


I did it, and it now compiles the kernel without errors.

I am now hanging on a problem compiling the ftpd application included in the 
latest dist 030305.

This is my error message:
In file included from auth.c:10:
crypt.h:33: conflicting types for `crypt'
/home/rgegusch/test/coldfire/uClinux-dist-patched/lib/libc/include/unistd.h:27: 
previous declaration of `crypt'
auth.c: In function `auth_user':
auth.c:105: warning: assignment makes pointer from integer without a cast
auth.c: In function `auth_pass':
auth.c:156: warning: passing arg 1 of `crypt' discards qualifiers from pointer 
target type
make[2]: *** [auth.o] Fehler 1
make[2]: Leaving of directory Directory: 
»/home/rgegusch/test/coldfire/uClinux-dist-patched/user/ftpd«


I am little bit confused. Looks like a generell problem with this app.
However, I am a little bit disappointed. No one ever gave me an answer 
regarding the FTP Server under uClinux.
Does you have an hints what to do?

Regards,
Rene



Am Sonntag, 23. März 2003 23:56 schrieb David McCullough:
> Jivin Rene Gegusch lays it down ...
>
> > Do you maybe mean the "flashloader" option?
>
> You will need the flashloader and bootloader options turned off.
>
> > Well, I really would like to have a flashloader, but anyway I was really
> > surprised about your and Greg's mail, which both said, that I would have
> > to disable the himemloader option. But the joke is: it is DISABLED.
> > Confuses me...
>
> The are in the same directory,  so turning on either option builds both
> tools,  but on the ones you select are installed in the romfs.
>
> Both of these tools are Lineo/Arcturus bootloader specific.  Unless you
> are using one of those boards, they are unlikely to be useful. Have a
> look at flashw/netflash which are more general purpose blkmem/MTD flash
> tools,
>
> Cheers,
> Davidm





More information about the uClinux-dev mailing list