[uClinux-dev] Init not found !!!

Santosh Bhat sanbhat at globaledgesoft.com
Sat Mar 22 06:26:27 EST 2003


Hi List; I am able to port my arm system so far!! Can anybody tell me what
is the problem I am facing (Kernel panic: No init found.  Try passing init=
option to kernel.)??
I digged around a lot of material on the uclinux mailing list and other
sources!! But not much use. Here is the screen shot

----------------------------------------------------------------------------
--------------
Linux version 2.4.17-uc0 (root at gesl) (gcc version 2.95.3 20010315
(release)(ColdFire patches - 20010318 from
http://fiddes.net/coldfire/)(-msep-data patches)) #3 Sat Mar 22 16:57:05 IST
2003
Processor: Samsung S3C4510B revision 6
Architecture: SNDS100
DRAM_BASE : 0
 DRAM_SIZE : 800000
 PAGE_OFFSET : c000000
 PHYS_OFFSET : c000000
 END_MEM : c800000
 MEM_SIZE : 800000
On node 0 totalpages: 2048
zone(0): 0 pages.
zone(1): 2048 pages.
zone(2): 0 pages.
Kernel command line: root=/dev/rom0
Calibrating delay loop... 39.21 BogoMIPS
Memory: 8MB = 8MB total
Memory: 7400KB available (453K code, 138K data, 28K init)
Dentry-cache hash table entries: 1024 (order: 1, 8192 bytes)
Inode-cache hash table entries: 512 (order: 0, 4096 bytes)
Mount-cache hash table entries: 512 (order: 0, 4096 bytes)
Buffer-cache hash table entries: 1024 (order: 0, 4096 bytes)
Page-cache hash table entries: 2048 (order: 1, 8192 bytes)
POSIX conformance testing by UNIFIX
Linux NET4.0 for Linux 2.4
Based upon Swansea University Computer Society NET3.039
Starting kswapd
Samsung S3C4510 Serial driver version 0.9 (2001-12-27) with no serial
options enabled
                ttyS00 at 0x3ffd000 (irq = 5) is a S3C4510B
ttyS01 at 0x3ffe000 (irq = 7) is a S3C4510B
block: 64 slots per queue, batch=16
Blkmem copyright 1998,1999 D. Jeff Dionne
Blkmem copyright 1998 Kenneth Albanowski
Blkmem 1 disk images:
0: C069008-C080407 [VIRTUAL C069008-C080407] (RO)
VFS: Mounted root (romfs filesystem) readonly.
Freeing init memory: 28K
Warning: unable to open an initial console.
Kernel panic: No init found.  Try passing init= option to kernel.
======>What is the problem here ??????




More information about the uClinux-dev mailing list