[uClinux-dev] How to confirm the mtd device has been added successfully? I need your help!

Massimo Calò m.calo at ctsgroup.it
Wed Mar 19 08:47:33 EST 2003


Hi,

    I have MTD and JFFS2 running on my 5272 board.

 vi /proc/mtd

                dev:    size   erasesize  name
                mtd0: 00030000 00010000 "Colilo/dBug (192K)"
                mtd1: 000d0000 00010000 "Kernel (832K)"
                mtd2: 00100000 00010000 "User (1024K)"

 vi /proc/devices

                Character devices:
              1 mem
              2 pty
              3 ttyp
              4 ttyS
              5 cua
             10 misc
             90 mtd
            100 ctsnvram
            108 ppp
            162 raw

Hope this can help you.

Ciao,

    Massimo.
  ----- Original Message ----- 
  From: 杨亚军 
  To: uclinux-dev at uclinux.org 
  Sent: Wednesday, March 19, 2003 10:49 AM
  Subject: [uClinux-dev] How to confirm the mtd device has been added successfully? I need your help!


      I want to support jffs on my 5272 board.  I use mtd and create two partitons. But I can't mount it successfully.  I guess that the mtd device have not benn added successfully. So I go to /proc and find that in /proc/devices, there is no mtd device's info.  In /proc/mtd ,there are two mtd devices---two partitions's info.

      Have my mtd devices been added successfully?

  I need your help!
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.uclinux.org/pipermail/uclinux-dev/attachments/20030319/a08c3a70/attachment.html>


More information about the uClinux-dev mailing list