[uClinux-dev] dist 20030305 doesn't build for Arcturus uC5272

Brad Clements bkc at murkworks.com
Tue Mar 18 20:34:37 EST 2003


Before diving in to "fix" I just want to confirm that no one else has tried and succeeded 
building a basic kernel for the Arcturus uC5272

I selected the board, and left all other settings as defaults. Make dep; make and get 
this:

make[2]: Entering directory `/var/local/src/uClinux-dist/linux-2.4.x/arch/m68knommu/platform/5272'
make[2]: *** No rule to make target `/crt0_ram.S', needed by `/crt0_ram.o'.  Stop.
make[2]: Leaving directory `/var/local/src/uClinux-dist/linux-2.4.x/arch/m68knommu/platform/5272'
make[1]: *** [_dir_arch/m68knommu/platform/5272] Error 2
make[1]: Leaving directory `/var/local/src/uClinux-dist/linux-2.4.x'
make: *** [linux] Error 1



The Arcturus uC5272 didn't work with previous dists either, probably because they just 
hadn't submitted the necessary patches. 

I just wanted to see if anyone else had this problem before I "dive in".

I see other 5272 users on the list using this dist, so .. maybe it's just my luck.

--  here's some things I've tried tinkering with tonight before sending this, based on my 
previously "working" dist (feb 2002 that came with Arcturus CD)

Snooping linux-2.4.x/arch/Boards.mk, I see I had this in my previous dist

#ifdef CONFIG_M5272
<snip>

ifdef CONFIG_BOARD_UC5272
BOARD := uC5272
endif

I also see I that in my "working" dist I have a

uClinux-coldfire/linux-2.4.x/arch/m68knommu/platform/5272/uC5272

With the necessary files:

total 40
drwxr-xr-x    2 bkc      bkc          4096 Jan 29 10:15 ./
drwxr-xr-x    5 bkc      bkc          4096 Jan 29 10:15 ../
-rw-rw-r--    1 bkc      bkc          1812 Jan 29 10:15 crt0_ram.o
-rw-r--r--    1 bkc      bkc          3882 Mar 26  2002 crt0_ram.S
-rw-r--r--    1 bkc      bkc          3158 Mar 26  2002 crt0_rom.S
-rw-r--r--    1 bkc      bkc          4615 Mar 26  2002 .gdbinit
-rw-r--r--    1 bkc      bkc          1569 Oct 31 14:59 ram.ld
-rw-r--r--    1 bkc      bkc            22 Jan 30 18:30 romfs.default.ld
-rw-r--r--    1 bkc      bkc            22 Jan 30 18:30 romfs.ld


Guess I'll copy these..
	
also need to edit config.in and add

        bool 'Arcturus Networks uC5272 dimm board support' CONFIG_BOARD_UC5272

added this to vendors/Arcturus/uC5272/config.linux-2.4.x

CONFIG_BOARD_UC5272=y


Now this is starting to smell bad. I'm beginning to think that my previous "fix" for this 
wasn't correct.

After all this, BOARDS still isn't being set correctly. :-(




-- 
Brad Clements,                bkc at murkworks.com   (315)268-1000
http://www.murkworks.com                          (315)268-9812 Fax
http://www.wecanstopspam.org/                   AOL-IM: BKClements




More information about the uClinux-dev mailing list