[uClinux-dev] FTP Server on the 5272 board

Rene Gegusch rgegusch at mf.tu-berlin.de
Mon Mar 17 04:30:16 EST 2003


OK, here is my report about my latest work:

first of all I reset everything, so that I had the exact distribution 
V.No.030305
then I downloaded the linux2.4 cvs directory and replaced in my uCLinux 
directory the mk68noemmu directory with the one from cvs

started make xconfig and reset every cahnges to default, then added ftp to it.
wondering that this time there was an extra question during default settings 
(in console):
Arcturus Networks uC5272 dimm board support (CONFIG_BOARD_UC5272) [N/y/?] 
(NEW)
Answer: y
make dep went on without any errors, but make gave me this error:
m68k-elf-gcc -fno-builtin -nostdinc -D__KERNEL__ 
-I/home/rgegusch/test/coldfire/uClinux-dist-patched/linux-2.4.x/include  
-Wall -Wstrict-prototypes -Wno-trigraphs -O2 -fno-strict-aliasing -fno-common 
-fomit-frame-pointer -I/usr/local/lib/gcc-lib/m68k-elf/2.95.3/./include -pipe 
-DNO_MM -DNO_FPU -m5307 -Wa,-S -Wa,-m5307 -D__ELF__ -DMAGIC_ROM_PTR 
-DUTS_SYSNAME="uClinux" -D__linux__ -O1   -nostdinc -iwithprefix include 
-DKBUILD_BASENAME=fec  -c -o fec.o fec.c
fec.c: In function `fec_enet_init':
fec.c:1676: `fec_hwaddr' undeclared (first use in this function)
fec.c:1676: (Each undeclared identifier is reported only once
fec.c:1676: for each function it appears in.)
make[4]: *** [fec.o] Fehler 1
make[4]: Verlassen des Verzeichnisses Verzeichnis 
»/home/rgegusch/test/coldfire/uClinux-dist-patched/linux-2.4.x/drivers/net«
make[3]: *** [first_rule] Fehler 2
make[3]: Verlassen des Verzeichnisses Verzeichnis 
»/home/rgegusch/test/coldfire/uClinux-dist-patched/linux-2.4.x/drivers/net«
make[2]: *** [_subdir_net] Fehler 2
make[2]: Verlassen des Verzeichnisses Verzeichnis 
»/home/rgegusch/test/coldfire/uClinux-dist-patched/linux-2.4.x/drivers«
make[1]: *** [_dir_drivers] Fehler 2
make[1]: Verlassen des Verzeichnisses Verzeichnis 
»/home/rgegusch/test/coldfire/uClinux-dist-patched/linux-2.4.x«
make: *** [linux] Fehler 1

Well, this time there is a new kind of error... great :(

I will try on to patch the latest distribution with the Arcturus distribution 
regarding boards.mk and config.in file... during waiting for answer

Regards
Rene




Am Montag, 17. März 2003 02:41 schrieb Greg Ungerer:
> Hi Rene,
>
> Sorry for the slow response, I have been away the last few days.
>
> Rene Gegusch wrote:
> > OK, I followed your instructions and added the uC5272 directory,
> > furthermore I added several uC5272 informations to the
> > arch/m68knommu/config.in and Boards.mk files. Before I tried to replace
> > them with the ones from the Arcturus Distribution.
>
> You didn't take the uC5272 definitions from the original Arctururs
> Boards.mk into your new one.
>
> > Finally I got the same error and this made me sad.
>
> Fixup your Boards.mk, do another "make xconfig" and
> try again. Let me know what errors you hit after this.
>
> > Added the arch/m68knommu/config.in and Boards.mk files as an attachement.
> > Maybe I misunderstood there somehting.
> > The .old files are the origin Arcturus ones.
> > I also attached the uC5272 files for your CVS directory.
>
> Thanks. I have put these in the public CVS at cvs.uclinux.org.
> You can get the new Boards.mk and config.in from there if
> you want.
>
> Regards
> Greg
>
>
>
> ------------------------------------------------------------------------
> Greg Ungerer  --  Chief Software Wizard        EMAIL:  gerg at snapgear.com
> SnapGear Pty Ltd                               PHONE:    +61 7 3435 2888
> 825 Stanley St,                                  FAX:    +61 7 3891 3630
> Woolloongabba, QLD, 4102, Australia              WEB:   www.SnapGear.com
>
> _______________________________________________
> uClinux-dev mailing list
> uClinux-dev at uclinux.org
> http://mailman.uclinux.org/mailman/listinfo/uclinux-dev
> This message was resent by uclinux-dev at uclinux.org





More information about the uClinux-dev mailing list