[uClinux-dev] Re: Cdrom support??

Greg Ungerer gerg at snapgear.com
Sun Mar 16 07:45:29 EST 2003


Hi Kristof,

Kristof Bruyninckx wrote:
> I left the kernel 2.4.x for what it is for the moment
> and started trying with teh 2.0.x version and
> everything compiles (included cdrom support and iso
> 9660) without an error I already mounted a Hard Drive
> to the MC5249C3 with some MP3 files and I can play
> them.A bit fuzzy but it works. But what I am not able
> to do is to mount my CDROM.When I do mount the cdrom
> as device hda I get the following errors:
> (see attach)
> 
> know I think these are normal because I'm trying to
> mount a cdrom while this is for a Hard drive.  But
> during booting my bord sees this as hda. And I can't
> find the right device for it in the dir DEV.
> So my guess would be to make the device in this
> directory DEV on the pc and do MAKE again. But now my
> question is could this be correct and how do I do
> this? I already tried to chanche hda with mknod but i
> did not work or I have done something wrong? 

/dev/hda is the right device if you have a CDROM attached
as well. The type of ATA device does not matter, the device
name is only a name, it is the uderlying major/minor
numbers that matter.

Are you getting any interrupts from the device?
Check "cat /proc/interrupts".

Regards
Greg


------------------------------------------------------------------------
Greg Ungerer  --  Chief Software Wizard        EMAIL:  gerg at snapgear.com
SnapGear Pty Ltd                               PHONE:    +61 7 3435 2888
825 Stanley St,                                  FAX:    +61 7 3891 3630
Woolloongabba, QLD, 4102, Australia              WEB:   www.SnapGear.com




More information about the uClinux-dev mailing list