[uClinux-dev] m5727c3 ethernet question

Murat Loo bluetoothloo at lycos.com
Sun Mar 16 05:22:11 EST 2003


Hi,

I've been hepply using the ethernet driver for for Coldfire boards. Then "something" happened and now I can't use any networked enabled appilcation(telnet, nfs, ftp, ping...) because they can't connect. Yesterday after uclinux booted, I've typed the ifconfig eth0 <ip> command and then I've tried to ping the board. The ping didn't work at first but after some time it worked and I was able mount the nfs server. Then I've added the ifconfig command to /etc/rc and rebooted the board, the ethernet interface worked. But today,  when I ping the board from another machine, ping says XXX trasfer XXX lost %100 loss. I'm not able to mount the nfs server.
Here is the output of the ifconfig command
eth0      Link encap:Ethernet  HWaddr 6B:16:CA:B2:C0:24
          inet addr:139.179.13.100  Bcast:139.179.255.255 Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:557412 errors:1 dropped:0 overruns:0 frame:1
          TX packets:117 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:100
          Base address:0x840
The rx packets count increases evertime I give the ifconfig command.
What may be the problem here? 





_____________________________________________________________
Get 25MB, POP3, Spam Filtering with LYCOS MAIL PLUS for $19.95/year.
http://login.mail.lycos.com/brandPage.shtml?pageId=plus&ref=lmtplus



More information about the uClinux-dev mailing list