[uClinux-dev] MTD and jffs question?

Erwin Authried eauth at softsys.co.at
Sat Mar 15 03:53:26 EST 2003


Hi,
there should be no need to use blkmem anymore. Use MTD's mtdblock_ro driver
instead. You will need a device node mtdblock0. mtd0 is usually used as the
name of the character device.
     @mtdblock0,b,31,0
Mount with:
    mount -t jffs /dev/mtdblock0 /mnt

jffs doesn't actually use the block driver, it's just used as a handle for
the MTD device.

Regards,
Erwin
  -----Ursprüngliche Nachricht-----
  Von: uclinux-dev-admin at uclinux.org
[mailto:uclinux-dev-admin at uclinux.org]Im Auftrag von 杨亚军
  Gesendet: Samstag, 15. M?rz 2003 08:01
  An: uclinux-dev at uclinux.org
  Betreff: [uClinux-dev] MTD and jffs question?


  Hi,all
     I want to use jffs on my 5272 board,I used MTD. I created a partition
on my
   AMD 29lv16 flash,and mknod a inode under /dev:
                     mtd0 b 30 0
  When the board boot ,it shows that the partition is created
successfully.but
  when I run:
           mount -t jffs /dev/mtd0 /mnt
  It return errors like that:
           mount:Mounting /dev/mtd0 on /mnt failed:Unknown error 6
  I go to /proc and run:
             cat mtd
  It  returns:
            dev:        size     erasesize       name
            mtd0      00200000   00010000      "jffs (2M)"

  And when I run:
            cat devices
  Under "Block devices",it only shows:
            1  ramdisk
            31 Blkmem
  There is no mtd.(I use  blkmem to support Romfs at the same time)

  What should I do?
  Any help is appreciated!

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.uclinux.org/pipermail/uclinux-dev/attachments/20030315/de76549c/attachment.html>


More information about the uClinux-dev mailing list