[uClinux-dev] MTD and jffs question?

杨亚军 yangyajun at hisense.cngb.com
Sat Mar 15 02:01:01 EST 2003


Hi,all
   I want to use jffs on my 5272 board,I used MTD. I created a partition on my
 AMD 29lv16 flash,and mknod a inode under /dev:
                   mtd0 b 30 0 
When the board boot ,it shows that the partition is created successfully.but 
when I run:
         mount -t jffs /dev/mtd0 /mnt
It return errors like that:
         mount:Mounting /dev/mtd0 on /mnt failed:Unknown error 6
I go to /proc and run:
           cat mtd
It  returns:
          dev:        size     erasesize       name 
          mtd0      00200000   00010000      "jffs (2M)"   

And when I run:
          cat devices
Under "Block devices",it only shows:
          1  ramdisk
          31 Blkmem
There is no mtd.(I use  blkmem to support Romfs at the same time)

What should I do? 
Any help is appreciated!

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.uclinux.org/pipermail/uclinux-dev/attachments/20030315/add6f18b/attachment.html>


More information about the uClinux-dev mailing list