[uClinux-dev] ip masquarade support

Phil Wilshire philwil at earthlink.net
Thu Mar 13 08:31:04 EST 2003


Hi Roope,
Sorry that you are having some difficulties here.

One ppossible reason for the insmod crash is the need for more stack space in the insmod program.
try 
flthdr -s 20000 insmod ( or busybox)

best regards
  Phil Wilshire



Roope Anttinen wrote:
> 
> Tried that but it didn't help :(
> I now compiled the ip-tables stuff as modules.
> insmod ip_tables went ok but when inserting iptable_filter module...
> BANG - kernel crashes:
> 
> *** UNASSIGNED RESERVED 12 ***   FORMAT=2
> Current process id is 23
> BAD KERNEL TRAP: 00000000
> PC: [<00101f37>]
> SR: 2035  SP: 0011bcd2  a2: 0056215c
> d0: 00000000    d1: 00000000    d2: 00000000    d3: 10c7e900
> d4: 00101f37    d5: 00000000    a0: 0056218c    a1: 00000000
> Process telnetd (pid: 23, stackpage=0011b000)
> Frame format=2 instr addr=20000010
> Stack from 0011bd0a:
>         018c0004 8b9010c7 e9320004 79240000 00000000 00030011 bdfc0011
> bde810c7
>         e9320000 00000000 00200022 00000000 00000000 00047924 00101f37
> 00000000
>         0010d080 00000000 00000011 bdec0010 d8de0011 bdfc0000 00030000
> 00000004
>         79240010 dcc20000 000010c7 51180000 00030011 bdfc0000 00000004
> 792410c7
>         e9320000 00000004 79240000 00030000 00000000 00000000 00020003
> 67bc10c7
>         53b20004 8b900011 bdfc0000 00030000 00000004 79240011 bde810c7
> e9320000
> 
> On Wed, 2003-03-12 at 20:42, David E. Gelhar wrote:
> >
> > On Tuesday, March 11, 2003, at 03:32 AM, Roope Anttinen wrote:
> >
> > > Started all over with as stripped image as possible which does
> > > basically
> > > nothing more than boots...
> >
> >
> > One thing I noticed in your output  is that cs89x0_probe is "finding"
> > lots of bogus ethernet interfaces. The ioaddr of "0xFFE0" is supposed
> > to mean "don't probe". The same thing was happening to me with a
> > uCsimm; although it wasn't resulting in crashes. I don't know if this
> > is the cause of your problem, but it probably can't be good to have
> > these bogus ethernet devices running.
> >
> > This appears to be caused by some added ARM code in drivers/net/Space.c
> > that always calls cs89x0_probe for eth1..eth7 (if CONFIG_CS89x0) in the
> > arch-specific probes section, while the generic isa_probes section will
> > not probe for interfaces with a base addr of 0xFFE0.
> >
> > The obvious patch to that is to not call the arm-specific probes on a
> > non-ARM architecture:
> 
> _______________________________________________
> uClinux-dev mailing list
> uClinux-dev at uclinux.org
> http://mailman.uclinux.org/mailman/listinfo/uclinux-dev
> This message was resent by uclinux-dev at uclinux.org

-- 
SDCS -- System Design & Consulting Services LLC, http://www.sysdcs.com
** Embedded Linux Training **  email me for details  
630 Springhouse Sq., Leesburg VA 20175 t: 703 669 9766 f: 703 669 9768



More information about the uClinux-dev mailing list