[uClinux-dev] bdm driver installation failing

Justin Clacherty justin at tmq.com.au
Wed Mar 12 18:57:23 EST 2003


I've already done this.  Originally I was having a problem where the
driver would report that the /dev/bdmcf0 resource is busy, this was
because the install of linux I am running had lp, parport, adn
parport_pc running (still does from boot).  I do the rmmod after I boot
up (haven't got around to finding out how to get it to never load).

I know it isn't a hardware issue as I tested debugging under W2K using
the Metrowerks tools.  The interesting thing is that when I connect the
debugger under linux, the leds on the board seem to flicker, this does
not happen under windows, it is as though something is writing to the
parallel port (presumably resetting the board continuously).

Justin.

On Thu, 2003-03-13 at 02:04, Jeff Carr wrote:
> Try loading and unloading the parport and lp modules before you load the
> bdm one. 
> 
> insmod parport
> insmod lp
> rmmod lp
> rmmod parport_pc
> rmmod parport
> insmod bdm
> 
> Goodluck,
> Jeff
> 
> On Tue, 2003-03-11 at 00:19, Justin Clacherty wrote:
> > Hi,
> > 
> > I'm trying to set up debugging through the bdm in gdb.  I've installed
> > the bdm driver but when I run chk /dev/bdmcf0 the driver seems to be
> > failing to connect to the target.  I turned on debugging and it looks
> > like it is failing when it tries to read a register on the target. 
> > Below is the command I am using and its output, along with the
> relevant
> > output in /var/log/messages.  I'm using the P&E Micro wiggler that
> came
> > with our Motorola M5272C3 development board.  Does anyone know what I
> > might be doing wrong?
> > 
> > The commands I'm using with the output...
> > 
> > [justin at rhianna test]$ ./chk -d 4 /dev/bdmcf0
> > Driver Ver : 2.a
> > Processor  : Coldfire
> > Interface  : P&E Coldfire
> > Reading CSR failed: Invalid target command
> > [justin at rhianna test]$
> > 
> > /var/log/messages
> > 
> > Mar 11 15:57:32 rhianna kernel:  cf_pe_read_sysreg - Reg:0xf failed
> with
> > cmd 0x2d80, err = 217
> > Mar 11 15:57:32 rhianna kernel: debugFlag now 4
> > Mar 11 15:57:32 rhianna kernel: BDMioctl cmd:0x8004421e
> > Mar 11 15:57:32 rhianna kernel: BDMioctl cmd:0x8004421f
> > Mar 11 15:57:32 rhianna kernel: BDMioctl cmd:0x80044220
> > Mar 11 15:57:32 rhianna kernel: BDMioctl cmd:0x4201
> > Mar 11 15:57:32 rhianna kernel:  cf_pe_reset_chip
> > Mar 11 15:57:33 rhianna kernel: BDMioctl cmd:0xc0084215
> > Mar 11 15:57:33 rhianna kernel:  cf_pe_get_direct_status --
> Status:0x0,
> > sr:0x7e
> > Mar 11 15:57:33 rhianna kernel:  cf_pe_serial_clock -- send 0x2d80 
> > receive 0x1ffff
> > Mar 11 15:57:33 rhianna kernel:  cf_pe_serial_clock -- failure NVC,
> send
> > 0x2d80 receive 0x1ffff
> > Mar 11 15:57:33 rhianna kernel:  cf_pe_read_sysreg - Reg:0xf failed
> with
> > cmd 0x2d80, err = 217
> > Mar 11 15:57:33 rhianna kernel: BDMioctl cmd:0x40044207
> > Mar 11 15:57:33 rhianna kernel: debugFlag now 0
> > 
> > 
> > Regards,
> > Justin.
> > 
> > 
> > _______________________________________________
> > uClinux-dev mailing list
> > uClinux-dev at uclinux.org
> > http://mailman.uclinux.org/mailman/listinfo/uclinux-dev
> > This message was resent by uclinux-dev at uclinux.org
> > 





More information about the uClinux-dev mailing list