[uClinux-dev] Colilo hangs

Greg Evans gevans at vigilhealth.com
Mon Mar 10 18:37:41 EST 2003


Hi,

I have been working with the M5272C3 development board with uClinux-dist 20020927. I want to have Motorola's DBUG left in flash at 0xFFE00000 and install Colilo at 0xFFF00000. Using CF FLASHER, I programmed flash with colilo.bin file starting at 0xFFF00000. Next I programmed flash with a compressed file of image.bin (uclinux-dist) located at address 0xFFF40000 (note: I am using the M5272C3-1MB file for Colilo). Both binaries are programmed without any errors.

I ran dbug and tried "go fff00000". I received an illegal instruction error. If I "di fff00000" in dbug I noticed that the code does not actually start until 0xFFF00400 with a "nop". When I tried "go fff00400" dbug hangs and the only way to gain control is to reset the board.

How can I get Colilo to work with the M5272C3?

Thanks,

Greg Evans
gevans at vigilhealth.com
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.uclinux.org/pipermail/uclinux-dev/attachments/20030310/f921c7e2/attachment.html>


More information about the uClinux-dev mailing list