[uClinux-dev] Kernel compile stopped working.

Louis Swart louiss at cat.co.za
Wed Mar 5 05:19:33 EST 2003


I think I see the problem, still not sure how to fix it?
After "make menuconfig" I see the following:

*** End of Linux kernel configuration.
bash: Saving: command not found
<-------------------------------
*** Check the top-level Makefile for additional configuration.
*** Next, you must run 'make dep'.

config/setconfig: line 216: ln: command not found
<-------------------------------
[root at Linux-Test-PC1 uClinux-dist]#

It seems that the path to the commands are lost.
How do I fix this?

I wrote the rest before I saw what I wrote above, you may ignore it.
----------------------------------------------------------------------------
--------------
> What distribution are you using?
cd /
tar xvzf /my_path/m68k-elf-tools-20020410.tar.gz

cd /usr/src/
tar xvzf /my_path/uClinux-dist-20020927.tar.gz

I believe this is correct and is all that is required?
----------------------------------------------------------------------------
--------------
> What did you do after unpacking it?
Did a "make xconfig".
(Motorola/M5272C3) Vendor/Product
(linux-2.4.x) Kernel Version
(uC-libc) Libc Version
[*] Default all settings (lose changes)
----------------------------------------------------------------------------
--------------
> Does this happen with a fresh unpacked uClinux-dist?
Yes, I deleted it after it stopped working and unpacked a new one, still the
same result.
Also reboot ed the box. Also deleted, I think part of, the tool chain and
unpacked it again.
----------------------------------------------------------------------------
--------------
> The ARCH and CROSS_COMPILE build variables
> are not set.
OK, why would they get lost?
Who sets them up in the first place?
How do I set them again?
----------------------------------------------------------------------------
--------------
> Did you do a "make menuconfig" (or "make xconfig") and choose your
> target board?
Yes, tried both.
----------------------------------------------------------------------------
--------------

----- Original Message -----
From: "Heiko Degenhardt" <heiko.degenhardt at sentec-elektronik.de>
To: <uclinux-dev at uclinux.org>
Sent: Wednesday,05 March 2003 10:01
Subject: Re: [uClinux-dev] Kernel compile stopped working.


> Hi Louis,
>
> * On Wed, Mar 05, 2003 at 08:56:05AM +0200, Louis Swart wrote:
> > My kernel compile stopped working, now only gives me the error below:
> >
> > [root at Linux-Test-PC1 uClinux-dist]# make dep
> > make ARCH= CROSS_COMPILE= -C linux-2.0.x dep
> > make[1]: Entering directory `/usr/src/uClinux-dist/linux-2.0.x'
> > Makefile:198: arch//Makefile: No such file or directory
> > make[1]: *** No rule to make target `arch//Makefile'.  Stop.
> > make[1]: Leaving directory `/usr/src/uClinux-dist/linux-2.0.x'
> > make: *** [dep] Error 2
> > [root at Linux-Test-PC1 uClinux-dist]#
>
> cauld you be a bit more specific? What distribution are you using?
> What did you do after unpacking it? Does this happen with a fresh
> unpacked uClinux-dist? The ARCH and CROSS_COMPILE build variables
> are not set.
> Did you do a "make menuconfig" (or "make xconfig") and choose your
> target board?
>
> Rgds.
> Heiko.
> _______________________________________________
> uClinux-dev mailing list
> uClinux-dev at uclinux.org
> http://mailman.uclinux.org/mailman/listinfo/uclinux-dev
> This message was resent by uclinux-dev at uclinux.org
>




More information about the uClinux-dev mailing list