[uClinux-dev] uClinux/ARM/GDB boot problems

Juliano Stedile jstedile at hotmail.com
Wed Nov 20 13:58:52 EST 2002


Hi all,

We are a group working at the university located at Brazil.

We have downloaded the last version of uClinux from the
webpage, and tried to compile it to the ARM target, with
little success.

When we load the kernel image on the GDB, it boots up
to a point where the system crashes and goes back to
the emulator showing a SIGINT error, as you can see in the GDB output
file attached.
Apparently we are stuck in an error on the blkmem.c code,
on the ramdisk initialization...

Some useful data you might need about our environment:

- Host is a Red-Hat Linux 7.2, running on intel hardware;
- uClinux is version 20020927
- we are compiling a minimalist setup (space is crucial)(*);
- we have the latest arm-elf-toolchain downloaded from the
  uClinux.org site, version is 20011119;
- the GDB we are using is the one that comes with the ARM
  toolchain, its version is 5.0;
- we tried compiling both little and big(-EB) endian targets with
  no success;
- target is a Atmel 91x40 ARM processor, memory/flash sizes and
  addresses left at the default, platform selected is 'GDB/ARMulator';
- using the 2.4.19-uc1 kernel shipped with the uClinux distro;
- always running "make clean" before compilation :-)


(*) By minimalist, we mean just kernel and minimal support
to get the system running. No network, ext2fs support, only
applications are init, login and sash, ramdisk and romfs only.
This excludes most of the application code from the compilation,
and therefore they are unrelated to the problem we are having.

We have tried to run the compiled image made available in
uClinux.org site on the GDB and it also crashed (output attached) 
..................

Where can we go from here? We're kind of in a hurry, our deadline
is nearing us....

TIA,
Juliano




_________________________________________________________________
MSN Hotmail, o maior webmail do Brasil. http://www.hotmail.com
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: error_Customized.txt
URL: <http://mailman.uclinux.org/pipermail/uclinux-dev/attachments/20021120/fb2f0a92/attachment.txt>
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: error_uClinuxImage.txt
URL: <http://mailman.uclinux.org/pipermail/uclinux-dev/attachments/20021120/fb2f0a92/attachment-0001.txt>


More information about the uClinux-dev mailing list