[uClinux-dev] Updating Built-in User Apps

gerg gerg at snapgear.com
Thu Aug 22 12:33:44 EDT 2002


Hi David,

David Chan wrote:
> Over the last few weeks of getting familiar with the uClinux
> distribution, it seems to me that the user-land apps that are
> distributed with the source tree need a little maintenance.
> 
> I've run into several cases where apps are listed as configuration
> options but it is very clear that they are _known_ to not compile. In
> addition, a lot of the packages are several years old compared to their
> stock cousins. 

I think you need to qualify the "known not to compile". Some apps
are know not to compile in certain configurations.


> For example, I wanted to use a bash shell to run a fairly complex shell
> script, so I selected it as my default shell instead of Sash. Bash fails
> to compile. After checking the mailing list, I come across an e-mail
> from Davidm: http://www.uclinux.org/pub/uClinux/archive/6192.html 
> To paraphrase: "Can I use bash in uClinux? Nope. Try the minix shell." 
> (Another response suggested using the busybox shell.) 

If you select one of the x86 vendor targets in the tree you can build 
bash...


> I tried to compile nwsh, but it turns out that some config files said
> the config target was CONFIG_USER_NWSH_NWSH and others said it was
> CONFIG_USER_NWSH_SH. Thus, when enabling it, it didn't end up compiling.
> After some quick fixes, it did actually compile.
> 
> Another example, I took the advice on the ColdFire port page to NFS
> mount my native development box to ease my development cycle. After
> switching the kernel version to 2.4.x, I found myself with a NFS mount
> that would not compile. Shocked and slightly frustrated, I scoured the
> mailing list again and found this e-mail from Matthais Schoeldgen:
> http://www.uclinux.org/pub/uClinux/archive/8568.html
> Again, to paraphrase: "Mount with NFS support won't compile under 2.4.
> Use the busybox mount." Ok. I would have thought there would be a
> version of mount out there that could support 2.4.x NFS by now.
> 
> And since BusyBox seems to be the proper way to implement a lot of
> significant functionality under uClinux, it needs to be updated. BusyBox
> 0.60.3, which contains several critical bug fixes (such as a working ash
> exec), was released back in April 2002, but the July 2002 release of the
> uClinux tree only included BusyBox 0.60.0, which was released way back
> in August 2001. 
> 
> And although it's only a small example, the UCD-SNMP needs updating as
> well. The 4.1.2 release in the July 2002 release of uClinux was released
> back in February 2000. NET-SNMP (as it's now called) released version
> 5.0.1 in May 2002. (They've since released 5.0.3 as of August 5th.)
> 
> Samba 2.2.5 was released in June 2002, but Samba 2.0.7, which was
> released in April 2000 (with a known exploit hole), was included in the
> latest uClinux release. 

Well, heres the thing. Whoever needs these apps updated should do
it and post patches. Nobody has stepped up to do it yet...


> I tried browsing around the CVS archive (through the web interface) to
> see if there had been new packages checked in, but everything in the
> userland/ directory is, reportedly, 13 months old. 
> 
> Are there individual maintainers for the user-land packages?

No. That is part of the problem. There is really only a couple
of people who ever update these. And that is generally only done
on an "as needed" basis. There is no way davidm and I can track
every release of every app in the tree - there are just too
many of them.

Even updating a single app can be a big job. We often have to
make little changes to get apps working (especially the bug ones
like samba). Then someone has to test them toughly. This can
take a signifcant amount of effort.

As a maintainer I am not going to commit changes to a known
working package unless I know that the update is of better
quality that what is already there. Sometimes old versions of
thing are _good_.


> Perhaps a
> debian-like package maintenance model could be adopted. 

I don't see how this would really make any difference?
The problem currently is that there is not enough person
power appiled to keep everything up to date.

Regards
Greg



------------------------------------------------------------------------
Greg Ungerer  --  Chief Software Wizard        EMAIL:  gerg at snapgear.com
Snapgear Pty Ltd                               PHONE:    +61 7 3279 1822
825 Stanley St,                                  FAX:    +61 7 3279 1820
Woolloongabba, QLD, 4102, Australia              WEB:   www.SnapGear.com

This message resent by the uclinux-dev at uclinux.org list server http://www.uClinux.org/



More information about the uClinux-dev mailing list