[uClinux-dev] Question regarding ucLinux update for ucGardener/simm(fwd)

Tom Walsh tom at cyberiansoftware.com
Wed Nov 28 12:49:18 EST 2001


Per Winkvist wrote:
> 
> Hi,
> 
> On Wed, 28 Nov 2001, Claudio Duffini wrote:
> 
> > Hi Per
> >
> > Per Winkvist wrote:
> > >
> > > When I do a "mount -t nfs 192.168....:/foo /bar" I get NFS:NFS v3 not
> > > supported. mount ..... unknown error 22
> > > To get nfs mounts working do I need to add nfs support as a module to the
> > > kernel and recompile ? (Currently I only have slhc and isdn as modules)
> >
> > Not a module issue. I had the same problem until I discovered the "enable v3 NFS"
> > choice while in the 'make menuconfig' phase.
> 
> Jupps. I found out that was the case.
> I tried to set "make menuconfig" libc option to uClibc (the more complete
> if I understood). This time I could compile everything but the boot failed
> for me:
> 
> NET4: Unix domain sockets 1.0/SMP for Linux NET4.0.
> VFS: Mounted root (romfs filesystem) readonly.
> illegal instruction
> PC[00010f00] SSP[000effd8] USP[000c3fac]     BootstrapSP[0001ffb6]

Could you post more of your boot messages please?  Are you trying to
mount the root filesystem via nfs, or was your problem that you had
problems with nfs when you tried the mount from within the /etc/rc
script?

I do my mounts via the /etc/rc, here is my file for 2.4:

============= begin ==================
hostname ezsimm
 
# expand the ramdisk
expand /etc/ramfs.img /dev/ram0
 
# mount ramdisk, proc and nfs
mount -t ext2 /dev/ram0 /var
mount -t proc proc /proc
mkdir /var/tmp
mkdir /var/log
 
ifconfig lo 127.0.0.1
route add -net 127.0.0.0 netmask 255.0.0.0 lo
 
# ifconfig eth0 24.229.50.8 broadcast 24.229.50.255 netmask
255.255.255.0
# route add -net 24.229.50.0 netmask 255.255.255.0 eth0
# route add default gw 24.229.50.1
 
ifconfig eth0 192.168.1.201 broadcast 192.168.1.255 netmask
255.255.255.0
route add -net 192.168.1.0 netmask 255.255.255.0 eth0
route add default gw 192.168.1.2
 
portmap &
mount -t nfs -o rsize=4096,wsize=4096 192.168.1.3:/home/opt/ez328lcd/pub
/usr

============= snip ===================

We have found that there is a problem with nfs with the slower MC68EZ328
processors.  I don't know if it exists in faster processors as the
MC68VZ328.  The problem shows itself when you try to move large files
(something > 20K), or cat large files to stdout from across the nfs. 
nfs would hang, if it happens to you, put in the rsize & wsize options
as I have done.

I see a more recent message from you about nfs is now working?  What
specifically did you do to clear up your problem?



TomW

-- 
Tom Walsh - WN3L - Embedded Systems Consultant
http://openhardware.net, http://cyberiansoftware.com
"Windows? No thanks, I have work to do..."
----------------------------------------------------
This message resent by the uclinux-dev at uclinux.org list server http://www.uClinux.org/



More information about the uClinux-dev mailing list