[uClinux-dev] Question regarding ucLinux update for ucGardener/simm (fwd)

Per Winkvist nd96pwt at adeptus.student.hig.se
Wed Nov 28 06:00:04 EST 2001



On Mon, 26 Nov 2001, Tom Walsh wrote:

> Per Winkvist wrote:
> > 
> > Hi,
> > 
> > I'm currently running the software that came with the cd (2.0.38,
> > gcc 2.7 cofff). When doing printf("%f") I get "LIBC:PRINTF" error so I
> > guess I need to update to newer libc (since the one I have has just stubs
> > for float)
> > 
> > I tried to get latest uclibc but my gcc 2.7 compiler couldn't compile it.
> > I tried to update compiler to 2.95 but got error from as.
> > 
> > I would like to have the 2.95 compiler since I have bumped into a couple
> > of oddities with the current one. Doing floating point is needed too.
> > 
> > Is Bernhard Kuhn's <http://www.uclinux.org/pub/uClinux/archive/2741.html>
> > description the way to update my system ?
> > 
> > Any suggestions are greatly appreciated!
> 
> Discard the CDROM and put your development system together using the
> latest uClinux-distribution + latest Elf development tools?
> 
Ok

> IIRC, uClibc development has been under elf, not PIC.  The PIC/coff
> compiler is outdated, you are stuck with all the limitations imposed by
> that early PIC/coff development system.  This is why the elf development
> system was built, to overcome restricts that the PIC/coff system had.
> 
> I don't know how up to date that Bernhard's howto may be at this time. 
> Essentially, it is what you would have to do, see:
> http://www.openhardware.net/uClinux/ , as that page also has information
> on how to use the system once you have it in place.

I downloaded the binary m68k-elf-gcc 2001-07-16 and installed them in /
I downloaded Greg's uClinux-distribution tarball and extracted it under
/root/new

I did "export PATH=/usr/local/bin:$PATH"

I did "make menuconfig" and choose "Lineo/uCsimm". (kernel was 2.4 and
libc was uC-libc). No other option were chosen.

"make dep;make" which built everyting without any errors.

I reset my uCsimm and uploaded the new image.bin (fast, rx, "minicom
upload", program)

When I try to boot it I get
------------------------------------------
uCbootstrap v1.2 (c) Rt-Control
Autoboot in 5 seconds. <esc> to abort
e100: eth1 NIC Links is down
e100: eth1 NIC Link is up 10 Mbps halv dup..
Booting
Go!
------------------------------------------

and nothing more...

FLASH type 2249 [AM29LV160B]
MC68EZ328 uCgardener board

Perhaps "Lineo/uCsimm" option is wrong ? (even though the config.arch  
seems to be correct)

Any clues or hints are appreciated !


Thanks,
	Per Winkvist

This message resent by the uclinux-dev at uclinux.org list server http://www.uClinux.org/



More information about the uClinux-dev mailing list