[uClinux-dev] Question regarding ucLinux update for ucGardener/simm (fwd)

Tom Walsh tom at cyberiansoftware.com
Mon Nov 26 15:03:37 EST 2001


Per Winkvist wrote:
> 
> Hi,
> 
> I'm currently running the software that came with the cd (2.0.38,
> gcc 2.7 cofff). When doing printf("%f") I get "LIBC:PRINTF" error so I
> guess I need to update to newer libc (since the one I have has just stubs
> for float)
> 
> I tried to get latest uclibc but my gcc 2.7 compiler couldn't compile it.
> I tried to update compiler to 2.95 but got error from as.
> 
> I would like to have the 2.95 compiler since I have bumped into a couple
> of oddities with the current one. Doing floating point is needed too.
> 
> Is Bernhard Kuhn's <http://www.uclinux.org/pub/uClinux/archive/2741.html>
> description the way to update my system ?
> 
> Any suggestions are greatly appreciated!

Discard the CDROM and put your development system together using the
latest uClinux-distribution + latest Elf development tools?

IIRC, uClibc development has been under elf, not PIC.  The PIC/coff
compiler is outdated, you are stuck with all the limitations imposed by
that early PIC/coff development system.  This is why the elf development
system was built, to overcome restricts that the PIC/coff system had.

I don't know how up to date that Bernhard's howto may be at this time. 
Essentially, it is what you would have to do, see:
http://www.openhardware.net/uClinux/ , as that page also has information
on how to use the system once you have it in place.



TomW


-- 
Tom Walsh - WN3L - Embedded Systems Consultant
http://openhardware.net, http://cyberiansoftware.com
"Windows? No thanks, I have work to do..."
----------------------------------------------------
This message resent by the uclinux-dev at uclinux.org list server http://www.uClinux.org/



More information about the uClinux-dev mailing list