[uClinux-dev] errors with smbmount on M5272C3 target

Jimi Simpson j.simpson at pryormarking.com
Thu Nov 22 05:25:16 EST 2001


Hi,

I am in the midst of developing my first application under uClinux for
an M5272C3 target and have reached the stage where I need to smbmount
onto a shared network file server. I have built the default
Motorola/M5272 big ram configuration and noticed that by default
smbmount appears to have been included in the binary build. I have so
far tried various permutations of the smbmount command but I am failing
miserably to gain any success with this. Basically the command that I
have had most success with so far is one that has the following syntax:
-

smbmount //venus/users /mnt/shared -n -c venus -I 192.168.1.6 -U
jsimpson

This I am sure is of the form proposed in section 8 of the development
notes (follow link www.uclinux.org/ports/coldfire/notes.html ) however I
get the following error message: -

/>
/> smbmount //venus/users /mnt/shared -n -c venus -I 192.168.1.6 -U
jsimpson
smb_request in sock.c (debugging)
smb_request in sock.c (debugging)
smb_request in sock.c (debugging)
smb_read_super in inode.c (debugging)
smb_dont_catch_keepalive: server->data_ready == NULL
mount error: Invalid argument
Please look at smbmount's manual page for possible reasons
/>        

NOTE: some of the detail above is additional "debugging" info that I
have built into the source just to allow me to see where the problem is
being reported from. I am at a loss !!!

If anyone has any suggestions to help me, then these will be greatly
appreciated.

Best Regards

Jimi Simpson
Technical Development Engineer
jsimpson at pryormarking.com

This message resent by the uclinux-dev at uclinux.org list server http://www.uClinux.org/



More information about the uClinux-dev mailing list