[uClinux-dev] BDM help.

MQuicquaro at necinfrontia.com MQuicquaro at necinfrontia.com
Wed Nov 7 18:54:32 EST 2001






>From gdb "help display":

  Print value of expression EXP each time the program stops.
  /FMT may be used before EXP as in the "print" command.
  /FMT "i" or "s" or including a size-letter is allowed,
  as in the "x" command, and then EXP is used to get the address to
examine
  and examining is done as in the "x" command.

display is only supposed to print something when you stop
extecution in someway (breakpoint, CTRL-C, stepi, etc).

Sorry, I guess I should RTFM.


>  Coldfire debug module version is 0 (5206(e))
> (gdb) display/i $pc
> 2: x/i $pc  0xffe0a2be: btst #0,%a0@
>
> Well, it looks ok so far.  Then I try to continue and...
>
> (gdb) c
> Continuing.
>
> Program received signal SIGTRAP, Trace/breakpoint trap.
> 0xffe0a87a in ?? ()
> 1: x/i $pc  0xffe0a87a: movew #9984,%sr
>
> I get a trap although I know i don't have any trace/breakpoints set.

Odd. Try single stepping (stepi) through a few instructions.
Does it appear to be executing normally?


I can step through the code no problem.  Its just a problem when I
"continue".
I do a "target bdm /dev/bdmcf0" while running dBUG on the M5272C3 eval.
board.
Funny thing is that I get the same results whether I boot my PC with Linux
and run gdb, or whether I run under cygwin.  I'm not sure what that
suggests.
When I do a "continue" it seems to execute several instructions, maybe 10
or so,
and then stop with a message about SIGTRAP,....

Could it be the CMOS settings on my LPT1.  I have it set for ECP, although
I've
tried all the other options too, EPP, Bi-directional.

Any help would be great.

- Mike

This message resent by the uclinux-dev at uclinux.org list server http://www.uClinux.org/



More information about the uClinux-dev mailing list