[uClinux-dev] BDM help.

MQuicquaro at necinfrontia.com MQuicquaro at necinfrontia.com
Mon Nov 5 19:25:29 EST 2001


Hello all,

I'm trying to connect to my M5272C3 board via the BDM port.
I have installed the bdm module and the "chk" utility seems to pass when
I run it.  When I try to connect to the BDM port via gdb (I'm using the one
in
the tools directory of the uClinux-coldfire dist.) with the command
"target bdm /dev/bdmcf0"  I notice that the board seems to get reset once
or twice, but then I get the error message
"BDM Error: Invalid Argument"
in gdb.

What could this possible be?  I've looked at the permissions of the /dev
file and it looks
ok. (I think).

 crw-rw-rw-    1 root     root      34,   4 Nov  5  2001 /dev/bdmcf0

I tried running gdb as su also without better results.  Can anyone help.

Thanks,
Michael Quicquaro
mquicquaro at necinfrontia.com
This message resent by the uclinux-dev at uclinux.org list server http://www.uClinux.org/



More information about the uClinux-dev mailing list