[uClinux-dev] 5272, bootloader, and "Calibrating Delay Loops.."

gerg gerg at snapgear.com
Fri Nov 2 07:16:41 EST 2001


Hi Travis,

Travis Griggs wrote:
> Greg Ungerer wrote:
> > This is almost certainly an interrupt problem. The first thing
> > I would check is what you have the PIVR register to. uClinux
> > expects it to be set to 0x40. (It does not power on reset to
> > this value, and dBUG sets it to 0x40). This setting bases the
> > interrtupts at 64 on up.
> 
> Hmmm.... I'm getting so close I can feel it. :)
> 
> As soon as I put this code in, it hangs colilo. It just sits there. I
> tried it in the initial part of colilo's main.c right after chip
> selects. I put it just before it jumps to startimage. Either way, it
> just sits there after I set the PIVR registry (mbar + 0x3F) to 0x40.
> There must be something else I need to do in conjunction with this.

Did you only write a single 8 bit quantity (unsigned char)?

You may also want to check the settings for the GPIO port registers.
I suggest making them the same as dBUG does.

Regards
Greg



------------------------------------------------------------------------
Greg Ungerer  --  Chief Software Wizard        EMAIL:  gerg at snapgear.com
Snapgear                                       PHONE:    +61 7 3279 1822
825 Stanley St,                                  FAX:    +61 7 3279 1820
Woolloogabba, QLD, 4102, Australia               WEB:   www.snapgear.com
This message resent by the uclinux-dev at uclinux.org list server http://www.uClinux.org/



More information about the uClinux-dev mailing list